[BlueOnyx:06291] Re: SuPHP

Jeff Folk jfolk at qzoneinc.com
Tue Jan 11 09:52:40 EST 2011


Is GID (group ID) 504 site-admin? site-admin is GID 503 on my system... I think the user must be site-admin for suphp to work properly.

Make sure user UID 508 is a site-admin as a first step. Also, I usually set the suphp property, then I set web ownership in the GUI to the site-admin. I'm not sure if the order is critical.

HTH;
Jeff

On Jan 11, 2011, at 8:21 AM, MuntadaNet Webmaster wrote:

> I wanted to bump this topic because I am not sure if I am doing 
> something wrong of if there is a bug.
> 
> At 07:47 AM 1/8/2011, you wrote:
>> I can confirm I see the following in the logs when suPHP is enabled:
>> 
>> suphp_log
>> [Sat Jan 08 07:31:49 2011] [info] Executing
>> "/home/.sites/143/site2/web/wp-admin/index.php" as UID 508, GID 504
>> 
>> error_log
>> [Sat Jan 08 07:31:49 2011] [error] [client 173.79.9.185] PHP Warning:
>> require_once() [<a href='function.require-once'>function.requir
>> e-once</a>]: open_basedir restriction in effect. File(./admin.php) is not
>> within the allowed path(s): (/tmp/:/var/lib/php/session/) in
>> /home/.sites/143/site2/web/wp-admin/index.php on line 10
>> [Sat Jan 08 07:31:49 2011] [error] [client 173.79.9.185] PHP Warning:
>> require_once(./admin.php) [<a href='function.require-once'>func
>> tion.require-once</a>]: failed to open stream: Operation not permitted in
>> /home/.sites/143/site2/web/wp-admin/index.php on line 10
>> [Sat Jan 08 07:31:49 2011] [error] [client 173.79.9.185] PHP Fatal error:
>> require_once() [<a href='function.require'>function.require
>> </a>]: Failed opening required './admin.php'
>> (include_path='.:/usr/share/pear:/usr/share/php') in
>> /home/.sites/143/site2/web/wp-admin/
>> index.php on line 10
>> 
>> I thought Michael addresses this behavior some time ago where the php
>> configurations set for the site were being ignored.
>> 
>> -Rashid
>> 
>> On 1/8/11 7:25 AM, "Abdul Rashid Abdullah" <webmaster at muntada.com> wrote:
>> 
>>> I have installed a WordPress site for a client and I wanted to turn on
>>> suPHP.  I set the webowner to the siteadmin and then I enabled suPHP.  The
>>> moment I set the suPHP to enabled, the website returns a blank page.
>>> 
>>> Any ideas?
>>> 
>>> -Rashid
>>> 
>>> 
>>> _______________________________________________
>>> Blueonyx mailing list
>>> Blueonyx at blueonyx.it
>>> http://www.blueonyx.it/mailman/listinfo/blueonyx
>>> 
>> 
>> 
>> _______________________________________________
>> Blueonyx mailing list
>> Blueonyx at blueonyx.it
>> http://www.blueonyx.it/mailman/listinfo/blueonyx
> 
> _______________________________________________
> Blueonyx mailing list
> Blueonyx at blueonyx.it
> http://www.blueonyx.it/mailman/listinfo/blueonyx




More information about the Blueonyx mailing list