[BlueOnyx:08422] Re: OpenVZ template - can't start setup

Frank Soyer fsoyer at systea.net
Sun Sep 11 08:51:20 PET 2011


Wahoo what an answer. Thousand thanks Michael.
First just an information, Proxmox need a formatted name to correctly
display it in th GUI, with the form <OS>-<name>-<version>-<arch>.tar.gz.
Now I tried with your suggestions.
The first problem was that Proxmox (here a v1.8) need to have a
configuration file in /etc/vz/dists, to initialize the vm, however it
uses a "default" file.
So I copy dists/centos.conf to dists/blueonyx.conf (because the template
was renamed to  "blueonyx-xxxxxxxxxxx.tar.gz"), and it uses it now. I
note that there is a "scientific.conf" file which is exactly the same as
centos.conf (and blueonyx.conf, now :) ).
I setup venet (I used venet and veth last time without success).
No option in the Proxmox vm creation screen to setup quotas. I must
create the vm, then, before lauch it, return into the vm configuration
screen, tab "Options" and enable the user quotas. I leave the max IDs to
500, the default.

Starting the VM, I find :
- Two interfaces, venet0 (in 127.0.0.1) and venet0:0 (with the IP I
gave). Strange...
- No user admin
- The startup screen in the GUI doesn't work anymore.

Well. Bad.
Tried with SL6.1 template : same thing.

Eventually : do you know a command line vith vzctl to correctly create a
vm with the templates at devel.blueonyx.it/openvz/ ? Maybe can I try
this to see the differences with the command used by Proxmox ?

Thanks.

Le dimanche 11 septembre 2011 à 06:02 +0200, Michael Stauber a écrit :
> Hi Frank,
> 
> > I was testing a BlueOnyx install as openVZ container on a Proxmox
> > server.
> > I've downloaded templates from http://devel.blueonyx.it/openvz , the 5.5
> > and the 5.6 (I tried the two versions).
> 
> Actually try the BlueOnyx 5107R OS template, which you can find in the same 
> directory. The most recent one is this here:
> 
> http://devel.blueonyx.it/openvz/blueonyx-5107R-SL6.1-i386-BX11-20110903.tar.gz
>  
> > After renaming the template (or Proxmox can't see it) I can create and
> > start a VM with it, no problem.
> 
> Yeah, Proxmox has some weird ideas how OS templates should be named. Which is 
> a bit silly, as OpenVZ itself doesn't really care how an OS template is named.
> 
> > I launch a VNC console, I have the root prompt, it's OK, but I see that
> > there is no network-script.sh in /root. why? 
> 
> Because it's not needed. The script /root/network_settings.sh is only used on 
> the CD-Version of BlueOnyx, where it can be used to configure the network 
> settings.
> 
> In OpenVZ VPS's the network is already configured automatically for the VPS 
> through OpenVZ itself. When you create the VPS, you use "venet" network 
> devices and assign an IP to the VPS and when the VPS is created, this IP and 
> the necessary network config files are then automatically created by OpenVZ.
> 
> Additionally /root/network_settings.sh only deals with setting up eth network 
> devices and not the more secure venet devices that you find on OpenVZ.
> 
> Actually OpenVZ supports both eth and venet style network interfaces, but like 
> said: venet is more secure as it prevents that a VPS user can sniff the 
> network traffic of all other VPS's on the same node. Hence our BlueOnyx OS 
> templates use only venet and don't even work with eth style network interfaces 
> anymore.
> 
> > Now I launch the GUI. The "intro.html" page appears with the "start"
> > button, click on it... But nothing appends. It stays here, on
> > intro.html.
> 
> This is probably because your admin/root password was already changed during 
> or right after the VPS creation. The initial web based setup will not run if 
> the admin and root password are not set to "blueonyx" at the time of the 
> setup. You can set a real password in the web based setup.
> 
> If the "admin" user is missing after the setup of the VPS, then the most 
> likely probable cause for this is that the script that created it didn't run 
> or failed for another reason. For example it fails to run if you don't enable 
> 2nd Level Disk Quota for the VPS.
> 
> So here are the things to observe when creating a BlueOnyx VPS on Proxmox:
> 
> Rename the OS Template to whatever Proxmox needs it to be.
> 
> When you create the VPS based on the BlueOnyx OS template, the settings 
> outlined below must be used. I never used Proxmox, so I don't know what 
> options it shows in its GUI or how they are named exactly. Instead I refer to 
> the options as OpenVZ calls them:
> 
> - Use "venet" instead of "eth" style network devices.
> - Second level disk quota for the VPS must be enabled.
> - Don't set the admin/root password of the VPS to anything else but "blueonyx" 
> until you're done with the web based initial setup.
> 
> Additionally: Due to all the different setup scripts that run through first 
> time around that the VPS boots, it may take a moment until you can login. Best 
> practice is to let the VPS boot up entirely and then restart it before you 
> start to use it. That way all the constructors can run and can reconfigure the 
> system for usage. The reboot before you start using the VPS makes sure that 
> all services come up properly after the initial reconfiguration that happened 
> during the first boot.
> 




More information about the Blueonyx mailing list