[BlueOnyx:11169] Re: MDADM / FDISK problem

Richard Morgan richard at morgan-web.co.uk
Wed Aug 15 19:40:03 PET 2012


----- Original Message ----- 
From: "Michael Stauber" <mstauber at blueonyx.it>
To: "BlueOnyx General Mailing List" <blueonyx at mail.blueonyx.it>
Sent: Thursday, August 16, 2012 12:41 AM
Subject: [BlueOnyx:11168] Re: MDADM / FDISK problem


> Hi Richard,
>
>> I've got a bit of a problem with disks.  It was reporting a disk
>> failure, but when I replaced the faulty disk last week it didn't do the
>> RAID rebuild.
>
> I had a similar problem recently and this appears like the cause could
> be the same here:
>
> During install off the CD the disks are partitioned with Anaconda's Disk
> Druid. Which is fine.
>
> During RAID rebuilds fdisk is used to try to create the same partition
> layout on the replacement disk which exists already on the good disk of
> the RAID1 array.
>
> However: Disk Druid and fdisk partition slightly differently and
> typically fdisk has a hell of a lot of problems creating the very same
> partition size.
>
> Unless you help it along with sfdisk, which allows us to copy the
> existing partition table from one disk to another disk.
>
> I went through a metric ton of emails, after remembering that we had the
> same problem in 2006 and it had been fixed in mdchk. But somehow it
> apparently fell out of the BlueOnyx code again, because I don't see it
> in our current mdchk.
>
> Please run this command:
>
> /usr/bin/perl -pi -e "s/sfdisk -L/sfdisk --force -L/"  /etc/init.d/mdchk
>
> Then simply run this:
>
> /etc/init.d/mdchk
>


Hi Michael

Thank you very much for the email (I like the 'metric' ton bit... very 
precise).

I ran the command (and checked it did indeed add --force), but running 
/etc/init.d/mdchk didn't start the rebuild.

Just to be certain, I removed the empty partition from /dev/sdb in case that 
was stopping it, but to no avail.

One other thing I tried was to manually build the partitions.  Copying the 
partition table from sda to sdb is fine for the first partition, but won't 
let me create the second partition with a sector starting on block 64, so 
I'm still stumped.

Regards, Richard


> Finally check with "cat /proc/mdstat" if your RAID is rebuilding again.
>
> Let me know if that works and I'll publish a fixed mdchk init script via
> YUM.
>
> -- 
> With best regards
>
> Michael Stauber
> _______________________________________________
> Blueonyx mailing list
> Blueonyx at mail.blueonyx.it
> http://mail.blueonyx.it/mailman/listinfo/blueonyx 




More information about the Blueonyx mailing list