[BlueOnyx:17075] Re: JSON

Richard Sidlin richard at sidlin.co.uk
Thu Feb 19 09:14:39 PET 2015


> 
> Hi Richard,
> 
> > They are saying that it doesn't appear to be parsing Json but does on
> > a test server they have. Would there be a specific error log that
> > would show this or how would I go about troubleshooting this?
> 
> Depends. It's a PHP script, so the errors should go into
> /var/log/httpd/error_log - unless the php.ini or the runtime configuration
of
> the script tell it to not log errors.
> 
> Best way to test this would be a simple JSON test script:
> 
> 
> <?php
> $arr = array('a' => 1, 'b' => 2, 'c' => 3, 'd' => 4, 'e' => 5); echo
"<pre>";
> print_r($arr); echo "</pre><br>"; $encode = json_encode($arr); echo
> "<pre>" . $encode . "</pre><br>"; $decode = json_decode($encode); echo
> "<pre>"; print_r($decode); echo "</pre><br>"; ?>
> 
> That sets up an array and prints it. Then it encodes an array in JSON and
prints
> it, too. Then it decodes that JSON encoded array and prints it again.
> 
> This will verify whether encoding and decoding via JSON work.
> 
> Most likely it will work for you, too. Which will then raise the question
about
> why the "other script" doesn't work.
> 
> The real question there is:
> 
> What does it try to encode/decode via JSON? Where does that JSON-blob
> come from? Is that file readable, has it the correct UID/GID? Does it
contain
> an array or JSON encoded array to begin with?
> 
> If the "other script" is trying to JSON-decode something from an remote
URL,
> then most likely it runs into the restrictive PHP security settings that
usually
> deny "allow_url_fopen".
> 
> So I'd suggest to take a closer look at what that "other script" does and
> where it gets its data from for the JSON encoding/decoding. The problem is
> probably not JSON, but basic access rights or security settings of PHP.
> 
> --
> With best regards
> 
> Michael Stauber

Hi Michael

We have tried all sorts of things but nothing works. We have even tried
building two different versions of BlueOnyx but that still doesn't work. Can
I demonstrate what the problem is?

Take a look at http://www.downyourhighstreet.com/garden/garden-furniture

And then compare it with the same that they have on a test site with Heart
Internet in the UK at http://79.170.44.91/dyhs.com/garden/garden-furniture

You will see filters down the left hand side (Material & Season). That is
what is missing on the live site. We took a complete copy of the temp site
and placed it on a brand new BO server. Still no filters. Can you suggest
anything as there doesn't appear to be anything in the error logs and I have
no idea where to go to next!

Thanks

Richard





More information about the Blueonyx mailing list